RetroStone not booting/crashing/freezing - Hardware issue - Please post here.

Here is all the tutorials, FAQ and support for RetroStone
Jebe457
Posts: 1
Joined: Thu 27 Dec 2018 17:16

Re: RetroStone not booting/crashing/freezing - Hardware issue - Please post here.

Post by Jebe457 » Thu 27 Dec 2018 19:27

Let me summarize the situation before going through the required questions. I backed the RetroStone project on Kickstarter with a Limited Edition unit.

When I received it back in September I tried imaging it multiple times with multiple cards following the indicated instructions with win32 disk imager. All I got for my trouble was either scrolling text, black screen, hanging, or if I had the HDMI monitor plugged in corrupted color bands across the Linux boot screen where it effectively would hang during the boot process before actually starting Linux.

As RetrOrangePi talked about fixing the software side issues, I decided to put it to the side, and try again after they had a chance to address it. The current images are better in that I once after ~15 minutes did have the RetrOrangePi Full actually boot into EmuStation, froze after about 10 minutes, and refused to boot Linux in follow up attempts.

The current Supreme image is also better in that it doesn't have visual distortion bands when initially trying to boot Linux on the HDMI monitor. It fails to boot with multiple checks before it halts the boot process. I tried issuing the boot command to see if it would actually go through three times, and on the third time I got the distortion bands and a hard hang with a black screen on the actual handheld screen for my trouble...

The current error list is:
MMC: no card present
Card did not respond to voltage select!

Device 0: device type unknown
... is now current device
** Bad device usb 0 **
** Bad device usb 0 **
_sun8i_emac_eth_init: Timeout
missing environment variable: pxeuuid
missing environment variable: bootfile
this is followed by multiple attempts with ethernet@1c30000 attempting PHY auto negotiation before the timeouts eventually fail. When I played with this recently it did it twice before hanging on the third time with distortion bands.

I'm using a 32GB Sandisk Ultra A1 for the recent attempt, which is a different card from the previous attempts. I did notice when inspecting the card on my RPi 3B that Etcher setup the card so it has a single 4.81GB ext4 partition. I extended it with gparted, but that didn't change anything. At this point I feel like I should probably look at figuring out how to image it off the RPi because the way it's imaging the card is absurd.

I've not hardware modded it per video yet. Based on comments within that thread about black screen/scrolling text it sounded like you were indicating it needs to be swapped rather than hardware modded I thought it would be best to check in first.

I know I haven't went explicitly through the numbers, but I'm pretty sure I've addressed all of the parts that are relevant.

User avatar
Admin
Administrateur du site
Posts: 403
Joined: Sat 10 Dec 2016 13:12

Re: RetroStone not booting/crashing/freezing - Hardware issue - Please post here.

Post by Admin » Sun 30 Dec 2018 12:51

Hello,
If you have a unit from the first production and that it is not stable (boot fail/crashes/freeze) then it's best to have it replaced.

distortion bands are normal on HDMI when the unit boot. It first boot on HDMI, then switch to LCD after 5-10 seconds. This is why at the beginning the LCD is blue/white. After switching on LCD the HDMI have artifacts making bands.

The "MMC: no card present" though is usually the R23 boot problem. Removing R23 will remove this issue. However from what you tell me I have the feeling that your unit is not stable so it still need to be replace. Can you open a ticket on the website and we'll deal with replacing the unit. (in the ticket please post a link to this thread and your forum nickname so we can link it to you easily.)
Thanks
Pierre

Pagawan
Posts: 5
Joined: Fri 24 Aug 2018 12:44

Re: RetroStone not booting/crashing/freezing - Hardware issue - Please post here.

Post by Pagawan » Tue 1 Jan 2019 22:14

Hello there!
It seems that my retrostone kickstarter limited edition has a problem: Worked well until one week ago, but since, it sometimes completely crashes after a +/- 15 minutes play.

Screen turns black with white waves while i'm playing, and Retrostone turns off in a few seconds. This comes with a weird whistling.

I first though battery was empty, but it did it again with full battery.
Guess it's an Hardware issue, because I didn't recently change anything about software neither Os or roms.

Pierre, have you heard about some similar problem?
If yes, is there any solutions?

Here's my order number: #2KS-0153

Ps: If you contact me, please do it in french, it'd be easier, at least for me ;)

exile101
Posts: 7
Joined: Thu 3 Jan 2019 10:08

Re: RetroStone not booting/crashing/freezing - Hardware issue - Please post here.

Post by exile101 » Thu 3 Jan 2019 10:58

1-yes
2-yes
3-yes
4-yes
5-no
6-both official and supreme 1.3
7-yes
8-no
9-yes
10-slim official
11-yes
12-yes 6 times
13-I have now tried on 3 different cards
14-cannot test because System will not boot past black screen when it does rarely turn on
15-yes seems like a hardware problem, the system did not even last 1 hour
16-Order Number #8BC-8060


Hi, I received my retrostone today after a long wait. I installed the official image and followed the directions. Please note This is not my first time doing this, I am very familiar with how retro /orange pis work. After installing some nes rom and playing for about an hour, my system began acting crazy. It began to flicker on and off with the screen turning blue. I tried restarting the system but it would not boot after the orangepi logo.. just a black screen.
I made sure the system was fully charged and created a new image on a new sd card. This time it booted. When I plugged my usb into the stone to transfer my roms the screen started going crazy again flickering nonstop until the system went black again. This time I could hear an odd sound coming from the system sounded like a faint cry, and then it shut itself off. The system will now no longer boot at all just a black screen and sometime will not even power on. I understand that these things can happen, but I have waited a long time for your product to arrive and I hope we can resolve this issue as quickly as possible.

skottles
Posts: 2
Joined: Fri 4 Jan 2019 02:59

Re: RetroStone not booting/crashing/freezing - Hardware issue - Please post here.

Post by skottles » Fri 4 Jan 2019 03:01

1 - yes
2 - yes
3 - yes
4 - yes
5 - nothing connected
6 - etcher (mac), pibaker (mac)
7 - yes
8 - yes Gparted (linux)
9 - yes CanaKit charger
10 - FULL Latest
11 - yes
12 - yes
13 - no
13b - no
14 - currently not booting
15 - boot loop - shows blue screen and flashes during start up, but never seems to come out of it.
16 - backer number: 845
17 - you have my email

User avatar
Admin
Administrateur du site
Posts: 403
Joined: Sat 10 Dec 2016 13:12

Re: RetroStone not booting/crashing/freezing - Hardware issue - Please post here.

Post by Admin » Mon 7 Jan 2019 10:36

Pagawan wrote:
Tue 1 Jan 2019 22:14
Hello there!
It seems that my retrostone kickstarter limited edition has a problem: Worked well until one week ago, but since, it sometimes completely crashes after a +/- 15 minutes play.

Screen turns black with white waves while i'm playing, and Retrostone turns off in a few seconds. This comes with a weird whistling.

I first though battery was empty, but it did it again with full battery.
Guess it's an Hardware issue, because I didn't recently change anything about software neither Os or roms.

Pierre, have you heard about some similar problem?
If yes, is there any solutions?

Here's my order number: #2KS-0153

Ps: If you contact me, please do it in french, it'd be easier, at least for me ;)
Salut,
Il va falloir la remplacer alors. Peux tu ouvrir un ticket sur le site ? Comme ca tu créé un compte sur le site en même temps et pourra suivre le paquet dessus.
Fait référence à ton poste sur le forum (avec ton nickname) et que j'ai dit qu'il faut la remplacer.
Pierre

@Exile101 see my reply to your ticket.

User avatar
Admin
Administrateur du site
Posts: 403
Joined: Sat 10 Dec 2016 13:12

Re: RetroStone not booting/crashing/freezing - Hardware issue - Please post here.

Post by Admin » Mon 7 Jan 2019 10:41

skottles wrote:
Fri 4 Jan 2019 03:01
1 - yes
2 - yes
3 - yes
4 - yes
5 - nothing connected
6 - etcher (mac), pibaker (mac)
7 - yes
8 - yes Gparted (linux)
9 - yes CanaKit charger
10 - FULL Latest
11 - yes
12 - yes
13 - no
13b - no
14 - currently not booting
15 - boot loop - shows blue screen and flashes during start up, but never seems to come out of it.
16 - backer number: 845
17 - you have my email
Hi,
Is this problem new or has it been happening since the beginning? Please open a ticket on my website, mentionning you posted in the forum with your nickname. Also if you can post some pictures or very short videos it will help trouble shoot.
Pierre

skottles
Posts: 2
Joined: Fri 4 Jan 2019 02:59

Re: RetroStone not booting/crashing/freezing - Hardware issue - Please post here.

Post by skottles » Tue 8 Jan 2019 04:21

Admin wrote:
Mon 7 Jan 2019 10:41
Hi,
Is this problem new or has it been happening since the beginning? Please open a ticket on my website, mentionning you posted in the forum with your nickname. Also if you can post some pictures or very short videos it will help trouble shoot.
Pierre
Ive only attempted to use this a few times. Here is the sequence of what I remember doing:

- Restored image RetrOrangePi 4.2 FULL - booted fine
- Powered Off via software
- Copied Roms to the SD card via linux VM from another working RetroPi SD Card
- Powered on RetroStone - boot loop
- Erased SD card
- Restored image RetrOrangePi 4.2 FULL again
- Added a small amount roms
- Powered on RetroStone - booted correctly
- Powered off via software
- Copied over more roms
- Powered on RetroStone - booted correctly
- Did this a few more times and got most of the SD card filled
- Booted 2-3 times correctly - always powered off correctly
- Attempted to turn it on recently - Currently stuck in boot loop

I will send over photos and video as soon as I can.

Shadow__dio
Posts: 6
Joined: Fri 4 Jan 2019 02:06

Re: RetroStone not booting/crashing/freezing - Hardware issue - Please post here.

Post by Shadow__dio » Sat 23 Feb 2019 00:41

Pagawan wrote:
Tue 1 Jan 2019 22:14
Hello there!
It seems that my retrostone kickstarter limited edition has a problem: Worked well until one week ago, but since, it sometimes completely crashes after a +/- 15 minutes play.

Screen turns black with white waves while i'm playing, and Retrostone turns off in a few seconds. This comes with a weird whistling.

I first though battery was empty, but it did it again with full battery.
Guess it's an Hardware issue, because I didn't recently change anything about software neither Os or roms.

Pierre, have you heard about some similar problem?
If yes, is there any solutions?

Here's my order number: #2KS-0153

Ps: If you contact me, please do it in french, it'd be easier, at least for me ;)
I am having the same issue described by Pagawan, except that on the last reboot, now the system won't boot, it turns on though, the lcd screen shows the normal blue and white lines but it doesn't boot to armbian at all; I have tried 2 different flash cards with clean installs of RetroOrangePi RetrOrangePi_4.2_FULL_Armbian_5.59_Retrostone_Debian_jessie_default_3.4.113_desktop to no avail. I also tried to create a ticket in the main page but it doesn't let me create it.

My order Number is: #8BC-7271

Edit1: I tried connecting the device to a computer using the usb0 (I presume that's the number) and the Retrostone is recognized as an unknown device, I've been trying to get the computer to communicate with it to no avail, still no image via HDMI with or without SDcard and No boot at all, just the white screen with blue lines on top.

Edit2: Am I not able to create a ticket because I didn't not placed the order? It was a Christmas gift :(

User avatar
Admin
Administrateur du site
Posts: 403
Joined: Sat 10 Dec 2016 13:12

Re: RetroStone not booting/crashing/freezing - Hardware issue - Please post here.

Post by Admin » Mon 25 Feb 2019 17:11

Shadow__dio yes you can create a ticket anyway. You just need to create an account. Please say reference to your order number and this post.

Post Reply