ext4 errors - Retropie does not boot anymore

Here is all the tutorials, FAQ and support for RetroStone
Post Reply
tmuecksch
Posts: 14
Joined: Fri 8 Sep 2017 10:01

ext4 errors - Retropie does not boot anymore

Post by tmuecksch » Thu 6 Sep 2018 12:15

I flashed the SD card as described in the tutorial. And my RetroStone worked fine for a few hours.
I then switched it off (of course I use the "Shut Down System" function first and waited for the screen to go fully black). When I wanted to start it a few hours later it got stuck in the boot procedure and showed multiple ext4 errors (see picture attached).

I then thought, I might have switched off the RetroStone too early which corrupted the filesystem, so I decided to erase and re-flash the SD-Card. But the error still persists.

How can I fix this?
IMG_9469.JPG
IMG_9469.JPG (172.77 KiB) Viewed 1828 times
Best regards,
tmuecksch

tmuecksch
Posts: 14
Joined: Fri 8 Sep 2017 10:01

Re: ext4 errors - Retropie does not boot anymore

Post by tmuecksch » Thu 6 Sep 2018 14:06

I've tried another SD card. And the same problem is still present. Is it possible, that this is a hardware problem?

radiowaves
Posts: 5
Joined: Thu 6 Sep 2018 11:20

Re: ext4 errors - Retropie does not boot anymore

Post by radiowaves » Thu 6 Sep 2018 14:10

You have upper level led lit up. Is it possible you just do not have enough power to read SD card etc? Charge it first until lower led lits up.

tmuecksch
Posts: 14
Joined: Fri 8 Sep 2017 10:01

Re: ext4 errors - Retropie does not boot anymore

Post by tmuecksch » Thu 6 Sep 2018 18:02

Hi radiowaves.
Thanks for the response. I have charged the RetroStone for about 5 hours before I had the problem. So I think this might not be the cause. I will retry the charging and report back.

BTW: I'm using a 5V 2,4A charger.

Best regards
tmuecksch

tmuecksch
Posts: 14
Joined: Fri 8 Sep 2017 10:01

Re: ext4 errors - Retropie does not boot anymore

Post by tmuecksch » Thu 6 Sep 2018 21:35

Yep. After charging it, it started working again. Well that's strange. Why doesn't the LED for the low battery status light up?

User avatar
Admin
Administrateur du site
Posts: 470
Joined: Sat 10 Dec 2016 13:12

Re: ext4 errors - Retropie does not boot anymore

Post by Admin » Fri 7 Sep 2018 12:14

It might have been the retrorangepi version. They released a beta version that caused this problem, maybe you were using it? Have you redownloaded the image?

Is your system stable now?

tmuecksch
Posts: 14
Joined: Fri 8 Sep 2017 10:01

Re: ext4 errors - Retropie does not boot anymore

Post by tmuecksch » Fri 7 Sep 2018 13:23

Hi Pierre,

The problem is back... I just fully charged my RetroStone (LED4 turning on). Then I plugged in a LAN cable and started transferring ROMs, while the RetroStone was showing the EmulationStation Menu. After about 5 minutes suddenly the ext4 errors appeared on the display and the RetroStone stopped working.

I'm currently using the this Image:

http://www.retrorangepi.org/RetrOrangeP ... desktop.7z

User avatar
Admin
Administrateur du site
Posts: 470
Joined: Sat 10 Dec 2016 13:12

Re: ext4 errors - Retropie does not boot anymore

Post by Admin » Mon 10 Sep 2018 15:18

I am not sure about this problem, it appeared recently but I have never heard of it before, so I wonder if it's something that has changed in the retrorangepi or if it's hardware issue.

You formated in FAT32 correct?

Is it always happening or only when battery is low ? Is the on/off switch going correctly from one side to the other?

tmuecksch
Posts: 14
Joined: Fri 8 Sep 2017 10:01

Re: ext4 errors - Retropie does not boot anymore

Post by tmuecksch » Mon 10 Sep 2018 22:13

Hi Pierre,

I have recently installed a beta of retrorangepi and since then, I haven't had the error anymore.

Maybe it only is a bug in the latest retrorangepi version!


I've downloaded the beta here:
http://orangepi.club/showthread.php?tid=2668

User avatar
Admin
Administrateur du site
Posts: 470
Joined: Sat 10 Dec 2016 13:12

Re: ext4 errors - Retropie does not boot anymore

Post by Admin » Tue 11 Sep 2018 11:11

Good to hear!

Post Reply