Poor battery performance?

Here is all the tutorials, FAQ and support for RetroStone
Post Reply
tmuecksch
Posts: 14
Joined: Fri 8 Sep 2017 10:01

Poor battery performance?

Post by tmuecksch » Sat 8 Sep 2018 11:04

Hey guys,

as already discussed in this thread: viewtopic.php?f=19&t=1762
my RetroStone starts showing ext4 errors while booting if the battery might be low (the 2nd LED is NOT showing up). We assume that the battery may be low, because the errors disappear when I recharged the RetroStone.

Yesterday I fully charged the RetroStone (5V, 2,4 A charger) until LED 4 was showing up (and a few hours longer to be sure). I then played for only half an hour a PSX game. Afterwards I switched it off (Shutdown via menu + Power Switch after black screen).

This morning I wanted to play and the errors are back. After recharging it the errors are gone. This leads me to the conclusion that either the battery is poor or the power management system has some issues...

What can I do to fix this issue?

Peppuccio
Posts: 61
Joined: Wed 5 Sep 2018 15:02

Re: Poor battery performance?

Post by Peppuccio » Sat 8 Sep 2018 11:54

viewtopic.php?f=19&t=1757&sid=7cee6553d ... a76d579323

Pierre said that can be a hardware problem from the switch power ON/OFF button. The battery life is declared 4-5 our of contnue playing(?) according to the official site, but i think more powerful is the system of you using (32 bit like the PSX) more battery is is absorbed by the battery. The odroid go have an battery of 1200 mah vs the 3000mah of the Retrostone, and the odroid go have 10 hours of continue playing, but him just use emulators wich consume less battery (system at 8 bit).

txcforever
Posts: 12
Joined: Thu 6 Sep 2018 13:03

Re: Poor battery performance?

Post by txcforever » Sat 8 Sep 2018 17:24

Well, I kinda mention it in a different post, but it's a bit weird how the device handles low battery. The 2nd led light lights up when it's about to shut down because of the low charge, but way before that Retrostone starts to act up in various ways. The most obvious for me is that the screen starts to flicker. Then the card reader starts to not working properly. And the console finally freezes. Again all these before the low battery led activates. And it seems to need more power than the one it gets on the charger, so I can't just plug it in and continue playing.

tmuecksch
Posts: 14
Joined: Fri 8 Sep 2017 10:01

Re: Poor battery performance?

Post by tmuecksch » Tue 11 Sep 2018 11:00

Just for the record:

As I already stated in this thread: viewtopic.php?f=19&t=1762#p3342
The situation has improved for me by using a beta version of retrorangpi instead of the latest stable version.

Post Reply