RetroStone boot problem identified

Here is all the tutorials, FAQ and support for RetroStone
Posts: 14
Joined: Mon 20 Aug 2018 19:36

Re: RetroStone boot problem identified

Post by Beads3 » Fri 12 Oct 2018 23:15

Admin wrote:
Fri 12 Oct 2018 10:36
Beads3 wrote:
Thu 11 Oct 2018 23:15
Just to be clear...

Are you saying if this mod does not work for us, that the unit is most likely faulty? (this is assuming we have done everything correctly as far as flashing and formatting sd cards and all other proper procedures)

I ask because I have removed the resistor and bridged with solder. The white/ blue screen is now fixed and has not gotten hung up on this since the mod. However, it still only boots correctly every 5 maybe more tries. The errors on screen range from a long looping script that I cannot read to a black screen that never changes to going through the orangepi splash screen with sound then freezing after. Basically it still does something different almost every try.

I have bought an additional Samsung 32GB select sd card as well as use the 16GB that came with it. Both work similar and neither are better or worse it seems. This goes for both images supreme and slim plus as well.

With this information (I know its not everything you need to know) is it safe to say that my unit is faulty? or should I remain patient and wait till better images are produced?
I think your unit is indeed faulty from what you say. You flashed in FAT32? ExFAT can give this kind of behaviour too.
Check this post and if you can feedback on these we'll confirm if it needs to be replaced. viewtopic.php?f=19&t=1760

Edit: Just read your second message, so it seem it was FAT32 problem? Let me know if your problem persist in the future.

Im sorry, I see how my post was a little unclear concerning FAT32. I have always been formatting my SD cards in FAT32. I was using ApplePi Baker for my formatting and flashing from the start. I was trying to say instead of using ApplePi Baker to format my SD I used Disk Utility instead. For a while it seemed to be working better. But after leaving it for some time and trying to boot up it takes at least 5 tries before a successful boot. Then when I shutdown and boot back up the proper way it takes another 3 or so tries for a successful boot.

edit: I just filled out the questions on the post: viewtopic.php?f=19&t=1760

Posts: 29
Joined: Sat 25 Aug 2018 10:51

Re: RetroStone boot problem identified

Post by jutleys » Sat 13 Oct 2018 10:50

I tried this today and i can confirm just throwing a blob of solder on top carefully does the job see my picture just take your time i have got 5 out of 5 boots :)
IMG_0205.jpg (172.48 KiB) Viewed 4003 times

Posts: 9
Joined: Tue 4 Sep 2018 18:28

Re: RetroStone boot problem identified

Post by stepp » Sun 14 Oct 2018 14:11

I tried this mod before i pack it up and send it back.

The mod does not do anything different, still crashes on boot, every time something different happens, black screen, scrolling text then crash.

On the odd occasion it might boot but this has defiantly not fixed it for me.

Posts: 8
Joined: Mon 15 Oct 2018 03:23

Re: RetroStone boot problem identified

Post by Dahak » Mon 15 Oct 2018 03:28

I ordered a Retrostone on September 28th, and haven't received word that I made it through the waitlist yet. Does that mean mine will have the problem corrected when it does ship?

Posts: 21
Joined: Sun 19 Aug 2018 15:49

Re: RetroStone boot problem identified

Post by Brandon » Mon 15 Oct 2018 08:37

I've removed R23 and jumped the pads on two RetroStones.
They both boot up better now but still sometimes freeze during boot to a black screen.

This maybe unrelated but is still a problem I would like to fix. On boot up of the one unit (the other is fine), once I get to ES it wants me to configure the gamepad (the built in Retrostone Controle). It will not recognize the buttons, but if I wait about 1 minute, it will work with no problem.

If I ssh in to the unit, I can see that js0 is missing in "dev/input" and after about a minute it will show up there on it's own.
pi@RetrOrangePi:/dev/input$ ls
event0 event1 mice mouse0
pi@RetrOrangePi:/dev/input$ ls
event0 event1 event2 js0 mice mouse0

Also if I run sudo jstest /dev/input/js0, It will not find the Retrostone Controle unit about a minute. After that all buttons work.
pi@RetrOrangePi:/dev/input$ sudo jstest /dev/input/js0
Driver version is 2.1.0.
Joystick (RetroStone Controle) has 2 axes (X, Y) and 14 buttons (BtnX, BtnY, BtnZ, BtnTL, BtnTR, BtnTL2, BtnTR2, BtnSelect, BtnStart, BtnMode, BtnThumbL, BtnThumbR, ?, ?).
Testing ... (interrupt to exit)
Axes: 0: 258 1: 32767 Buttons: 0:off 1:off 2:off 3:off 4:off 5:off 6:off 7:off 8:off 9:off 10:off 11:off 12:off 13:off

BWT: (this is not important) I have not done the analog joystick mod yet, but did notice that jstest reports the Retrostone Controle D-Pad as 2 axes? the UP/DOWN/LEFT/RIGHT seem to be mapped to 32767 and -32767 with a middle spot of 258. This would seem to imply analog values like a potentiometer? Could an analog thumbstick be wired to the d-pads?

User avatar
Administrateur du site
Posts: 495
Joined: Sat 10 Dec 2016 13:12

Re: RetroStone boot problem identified

Post by Admin » Mon 15 Oct 2018 10:21

@Beads3 ok then it should be replaced. I'll send you an email about it.

@Dahak We have delayed shipping to fix this issue. We are reworking all the remaining PCB. Sorry for the delay!

@Brandon about the dpad not being recognize for one minute does it depends on the retrostone or does it depends on the SD card (ie image) ? I mean if you swap the SD card do you still have this problem?
I think this has been discussed on retrorangepi forum but I do not recall exactly.

About the Dpas being used as analog joystick it's because I used a pre-existing GPIO driver and did not modified that (as it's working ok like this). The initial drivers was using Dpads buttons as uinput event of joystick :

Code: Select all

		uinput.ABS_X + (0,255,0,0),
		uinput.ABS_Y + (0,255,0,0),
I modified that in the driver including the joystick that I wrote there :
To use instead the right uinput events :

Code: Select all


Posts: 8
Joined: Mon 15 Oct 2018 03:23

Re: RetroStone boot problem identified

Post by Dahak » Mon 15 Oct 2018 23:40

Admin wrote:
Mon 15 Oct 2018 10:21
@Dahak We have delayed shipping to fix this issue. We are reworking all the remaining PCB. Sorry for the delay!
No problem. I'm happy it is delayed if that means that boot issue will be fixed on mine. I was worried about that after ordering. :)

Posts: 16
Joined: Sun 26 Aug 2018 00:10

Re: RetroStone boot problem identified

Post by denis » Mon 15 Oct 2018 23:59

So i have done the fix too. The goods is that i haven t any fail boot tonight (nine try) but another issue appear on my device the retrostone input not reconize on boot of ES (tree times). I have to shutdown the device an Power it on again to make it work.
As we are two here (brandon and me) who get this issue maybe there something we have touch when open the device ? Solder ? Unplug Back button ?
It appear Strait after i made the fix and wasn t appear before. I think it s the hardware gamepad who are not reconize by ES. For me it s not a software issue.
I have done both boot and audio fix at same time.

User avatar
Administrateur du site
Posts: 495
Joined: Sat 10 Dec 2016 13:12

Re: RetroStone boot problem identified

Post by Admin » Tue 16 Oct 2018 10:40

When you have this problem it seems that the gamepad should be detected after 30seconds - 1 min of wait.

I am not sure where this problem can come from. I already read about it on retrorangepi forum. I think it's a problem with the driver not loading in time. I'll discuss it with retrorangepi developper. If you can report also this issue on their forum it would help.

I don't think this is a hardware problem linked to the fix of R23. It will probably be fixed in software.

Posts: 11
Joined: Tue 16 Oct 2018 22:52

Re: RetroStone boot problem identified

Post by Flom » Wed 17 Oct 2018 10:18

Bonjour à tous,

J'ai effectué la soudure (i ve done the fix). J'ai toujours des problèmes de boot...(i ve always some boot problems)
Dès que j'ai effectué la modification, au second boot j'ai eu des messages d'erreurs sur fond noir (cpu not detected). Au début j'ai été obligé de redémarrer la console et ensuite la console finissait par redémarrer elle même sur un boot correcte. But the black screen is Always here...
Finalement je ne conseil absolument pas ce fix ! Je préfèrerais mon écran noir tous les 2 ou 3 boot...
Mais comment revenir en arrière ? J'ai une soudure maintenant...

Post Reply