Page 1 of 1

Screen messed up? (ALL RESOLVED)

Posted: Thu 11 Oct 2018 07:16
by shamayimjosh
Photos attached

Edit: It seems my original photos did not upload?

Not sure what the problem is, should I just try to re-attached the ribbon?

There is no picture, i.e. signal etc, either when I plug it into my television with the HDMI out, is there something I need to do to get it to change over? N.B. have official Raspberry Pi HDMI mini to standard converter.

Also got two grey "L" buttons, and one has a broken element.


Re: Screen messed up?

Posted: Thu 11 Oct 2018 07:30
by shamayimjosh
Also, I could not find the assembly tutorial, so I just followed one of the videos, same YouTube channel as the promo video etc. But, thought I should mention this, because, just looked at the troubleshooting, and saw, that, the issue I have is documented. Basically, it seems I would need to install the software on the SD Card, did not know this, presumed you guy's would have that one covered. So, where can I find this assembly tutorial, because I have looked on the website etc, but have not found it? I was annoyed in the first place, that I had to click into the guy's YouTube channel, i.e. from your guy's website, just to find the one I used, since there was no assembly video on the website? Great video, none the less, credit there.


Re: Screen messed up?

Posted: Thu 11 Oct 2018 07:45
by shamayimjosh
Okay, this is a killer, sorry guy's. Found the links in the email.

I was pretty exited to get it assembled, as you could imagine. Now, trying to figure out how to determine when it is fully charged.

I am going to read this stuff.

Hey, I followed some other assembly video, i.e. one that covered it in far more detail, which I am quite glad about now.

Will see you soon, will post a pic once it is going!

Edit: Also, found the assembly link on the website also, I was so excited that I missed it all, N.B. I actually visited that page, and clicked into the troubleshooting section next to it, trying to find it, it is amazing that I did not see it.


Re: Screen messed up?

Posted: Thu 11 Oct 2018 09:15
by shamayimjosh
Have the screen working, which is great. But have another problem!

Seems it will not boot, and did find some info.. basically I will need to enter into recovery mode to change an option.

Problem is, I cannot enter into recovery mode, i.e. I have a wireless keyboard, and when I press "shift" it does nothing. So, tried a few different ways, i.e. one person suggested not to hold it down before powering it on, but after, but have also tried pressing rapidly etc.

Photos attached.

Any help would be great.

I did find a post, though, not on this forum, where, it is possible to forcefully boot into recovery mode
If you are unable to use either the GPIO or keyboard to trigger entering Recovery Mode, you can:

Append forcetrigger to the argument list in the recovery.cmdline file which is found in the root NOOBS directory.
Note that with this option enabled, the Recovery Mode will be displayed every time you boot from your NOOBS card (until you edit recovery.cmdline again).
Edit: So it says "end Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(179,2)"

Have retropie-4.4-rpi1_zero.img installed

Re: Screen messed up? (RESOLVED, but now have a problem booting)

Posted: Thu 11 Oct 2018 09:52
by shamayimjosh
Think I know what the problem will be, i.e. just checked the partition table of the SD Card etc, because, after I wrote the image, I got a message in windows asking, do you want to format some partition, and I said yes, thinking it was just one left over to put ROMs etc on, but, turns out, this is the partition the root file system would be on.

If I can give you guy's a bit of advice, do not use Rufus, at least the latest version 3.3, since it seemed to have messed up the write on my first try. I have done this sort of thing setting up Android on my Laptop/Tablet hybrid PC.. even then, I remember one of the image writers was faulty, but thought Rufus would be good, though, perhaps it was the latest version. It has been too long for me to check the details, but, I remember, the one that they recommended on their site, i.e. Android x86, worked. Will try again with Etcher-Portable for the second time, the first time, as I said, windows requested to format the partition, obviously it is EXT3 or whatever, for linux.

Looking forward to getting this done. As I said, will post a screenshot once I am done.

Gees, this has been challenging, seems, anything that I can mess up, I mess up, or otherwise, overlook. Cheers

Re: Screen messed up? (RESOLVED, but now have a problem booting)

Posted: Thu 11 Oct 2018 12:16
by shamayimjosh
So basically have everything configured etc, the only thing I need to get working is HDMI out, otherwise, all good. To get HDMI, just planning to enable to safe_hdmi option, or whatever it is, in "config.txt", but a little bit too tired. Should post a pic tomorrow, would have loved to have posted one tonight, but, a bit tired, and waiting for the thing to charge atm. Did see the warning, i.e. do not use it while it is charging, so, while I am tempted to login via SFTP and update that config, since I got Raspberry Pi Zero W, I will hold off for the time being, probably until tomorrow.

Edit: N.B. yes I double checked, since I remember reading somewhere that the latest could charge and play at the same time, and yes, it seems is so, i.e. after checking 8bcraft website.

Oh, one other thing, I seem to hear some faint noise etc, at times, from the speaker, but otherwise, all good, does anyone know what this is?

Will also better introduce myself then likewise.


Re: Screen messed up? (ALL RESOLVED)

Posted: Thu 11 Oct 2018 13:41
by shamayimjosh
So guy's, here is the final result. Photos attached

Now, it seems, the Raspiboy sits well, if not perfectly, on the 3DS cradle. Had to move the 3DS, N.B. SNES Edition too, unto its charging station, i.e. to find a place for it, but, would like another 3DS cradle, since, I prefer it than to the charging station.

So, got HDMI out working, not sure why I could not get it going the first time, but, after enabling safe_hdmi, it worked, but, the screen would not work without HDMI out at that point, so put it back, and now, both seem to work, must just be that you have to have HDMI out plugged in at the time of boot. I guess, when testing, I did not bother to reboot the system etc.