Broken Retrostone2 arrived

Please check here for help solving common issues.
alf.igel
Posts: 1
Joined: Sun 19 Jan 2020 16:59

Broken Retrostone2 arrived

Post by alf.igel » Sun 19 Jan 2020 17:05

My Retrostone2 arrived on 18.1.2020. I can turn it in, the blue light get on but the screen remains black. When I attach the device to the computer by USB the device is also not recognized.
Further the screen is totally scratched - Innever sae such a scrachted screen ever before.

I am totally disappointed and also sent a mail to Pierre-Louis Boyer and asked how to return the device.

Sakib
Posts: 82
Joined: Wed 19 Dec 2018 14:43

Re: Broken Retrostone2 arrived

Post by Sakib » Tue 21 Jan 2020 15:39

Hi can you please open a ticket on website with attached picture of your screen.. we will solve it.

Ferros
Posts: 2
Joined: Tue 21 Jan 2020 19:39

Re: Broken Retrostone2 arrived

Post by Ferros » Tue 21 Jan 2020 20:20

My retrostone2 arrived today. If I start it with the power button I see a blue led (on) if I charge it I see a second blue led beneath it. Did not flash the card yet. But is it normal that the screen Does not light up and Does not show anything? Should it not show something without an os on the card? Because then I have the same problem as the original poster

TheMikeBachmann
Posts: 7
Joined: Tue 21 Jan 2020 23:18

Re: Broken Retrostone2 arrived

Post by TheMikeBachmann » Tue 21 Jan 2020 23:20

I only just received mine. I don't know if this is your problem but I have not yet installed Retroorangepi on my device and it behaves as you described.

I do not believe the Retrostone 2 ships with any software on it so make sure you've installed it before you go through the trouble of sending it back.

User avatar
Admin
Administrateur du site
Posts: 470
Joined: Sat 10 Dec 2016 13:12

Re: Broken Retrostone2 arrived

Post by Admin » Wed 22 Jan 2020 10:58

Ferros wrote:
Tue 21 Jan 2020 20:20
My retrostone2 arrived today. If I start it with the power button I see a blue led (on) if I charge it I see a second blue led beneath it. Did not flash the card yet. But is it normal that the screen Does not light up and Does not show anything? Should it not show something without an os on the card? Because then I have the same problem as the original poster
It's normal that it does not show anything before flashing the card.

User avatar
Admin
Administrateur du site
Posts: 470
Joined: Sat 10 Dec 2016 13:12

Re: Broken Retrostone2 arrived

Post by Admin » Wed 22 Jan 2020 10:59

alf.igel wrote:
Sun 19 Jan 2020 17:05
My Retrostone2 arrived on 18.1.2020. I can turn it in, the blue light get on but the screen remains black. When I attach the device to the computer by USB the device is also not recognized.
Further the screen is totally scratched - Innever sae such a scrachted screen ever before.

I am totally disappointed and also sent a mail to Pierre-Louis Boyer and asked how to return the device.
Scratches on the screen are the protective film on the PC protector. Please try to peel it off from the border of the protector.

About the screen been black you need to install retrorangepi : https://www.8bcraft.com/Retrostone2-tutorial/

Ferros
Posts: 2
Joined: Tue 21 Jan 2020 19:39

Re: Broken Retrostone2 arrived

Post by Ferros » Wed 22 Jan 2020 19:27

Formatted on win10 fat32 (5Gb).
Flashed with balenaEtcher as administrator.
After that windows cannot read the card anymore wich would be normal?
I stick The card in retrostone2 But after the screen backlight flashes once (and a little green led) nothing happens. Waited a minimum of 2-3 minutes.
Is there a way to check if the flashed card is ok?
What next?

User avatar
Admin
Administrateur du site
Posts: 470
Joined: Sat 10 Dec 2016 13:12

Re: Broken Retrostone2 arrived

Post by Admin » Thu 23 Jan 2020 12:27

Ferros wrote:
Wed 22 Jan 2020 19:27
Formatted on win10 fat32 (5Gb).
Flashed with balenaEtcher as administrator.
After that windows cannot read the card anymore wich would be normal?
I stick The card in retrostone2 But after the screen backlight flashes once (and a little green led) nothing happens. Waited a minimum of 2-3 minutes.
Is there a way to check if the flashed card is ok?
What next?
What do you mean by 5Gb? there is probably some partitions leftover.
Please try to clean the SD card with diskpart as explained here : https://www.howtogeek.com/170794/ask-ht ... n-sd-card/
Then format as Fat32 and flash again. Wait about 5-10 minutes on first boot to make sure.

Yes it's normal you can't read the SD after flashing because linux use ext4 file system

StevenS757
Posts: 2
Joined: Tue 28 Jan 2020 14:29

Re: Broken Retrostone2 arrived

Post by StevenS757 » Tue 28 Jan 2020 14:34

I am having this same issue. I just received my RetroStone 2, imaged the SD card, charged the battery, and tried to turn it on. However, nothing ever comes up on the screen. It just stays black. The power LED is on, but nothing ever appears on the screen. I let it sit on for over 30 minutes. I don’t know if the unit is defective or if I’m doing something wrong.

I've submitted a support ticket.
Attachments
195657.jpg
195657.jpg (111.96 KiB) Viewed 259 times

Sakib
Posts: 82
Joined: Wed 19 Dec 2018 14:43

Re: Broken Retrostone2 arrived

Post by Sakib » Tue 28 Jan 2020 15:05

Hi Steven,
Replied you on your ticket.

Post Reply