Retrostone problems

Here is all the tutorials, FAQ and support for RetroStone
Post Reply
Posts: 2
Joined: Wed 15 Aug 2018 12:28

Retrostone problems

Post by Nevuor » Wed 15 Aug 2018 12:45

Hi there!
Finally got my Retrostone yesterday, was really excited to get it running! Unfortunately, I have a lot of problems with it...

Main problem is basically to get Retrorange running! It only boots like every 30th time I switch my Retrostone on! For the other 29 times, every boot seems to be different! At the start, I always get the 2/3 white, 1/3 blinking blue screen as described in the troubleshoot FAQ, but I guess this is normal?
So now to the problems... Sometimes it just stays like this, sometimes I get the image with the consoles and the "slim" text, then sometimes it gets dark and stays like this, but most of the time I get command lines, I've seem many of them, and they also seem to be different at every boot! Sometimes I get 2 lines, sometimes they keep running like forever with nubers counting the lines and so on... It's really frustrating!
When I get to run Retrorange, I get a blue screen which looks not to healthy on the screen and then the image with the mushroom appears and it loads, but as I said, this does't happen too often...

Since yesterday, I tried a lot to get my Retrostone running! I used different SD cards, redownloaded the image, tried to flash the image with Win32DiskImager as well as with Etcher, nothing worked...

Hope to get help soon, as I'm really impatient to get this thing running! :)

Thanks in advance!

Posts: 35
Joined: Wed 15 Aug 2018 16:49

Re: Retrostone problems

Post by dr_bunsen » Wed 15 Aug 2018 17:03

I had a similar problem and I found a solution. In my case the image didn't boot properly first time, so I tried to re-write the image on the same SD card. Again it wouldn't boot, so when I reformatted the card to exFAT to start the process over, I checked the partitions using the free section of Minitool Partition Wizard and found a 1.9Gb un-allocated portion of the card that Windows had not identified and subsequently not formatted. The 1.9Gb portion was probably a Linux partition I guess, which messed up future imaging. Anyway I reformatted with one partition for the whole SD and then re-imaged and it worked fine. Be patient when booting up, the screen blanks out and flashes several times and the whole process takes around five minutes.

Posts: 4
Joined: Tue 14 Aug 2018 10:01

Re: Retrostone problems

Post by lostinfuture » Wed 15 Aug 2018 19:06

Wow looks like your unit is really buggy, cause mine starts fine

Posts: 6
Joined: Sun 12 Aug 2018 04:26

Re: Retrostone problems

Post by KimDEa » Thu 16 Aug 2018 08:26

My retrostone are same problem too.
I don’t know why. Try to many turn off..

Posts: 8
Joined: Fri 17 Aug 2018 12:24

Re: Retrostone problems

Post by XorA » Fri 17 Aug 2018 12:35

Mine occasionally fails to boot, but its not often enough to be super annoying (and comparable to other ARM SBC's I have).

Do we know if there is a UART hidden anywhere so people can debug boot issues?

Posts: 7
Joined: Mon 14 Aug 2017 03:23

Re: Retrostone problems

Post by pbhound » Sat 18 Aug 2018 23:20

I had to use the RetrostonePi slim OS to get it to run on the retrostone.

I am having an issue (at least i hope its an issue and not that it does not exist) with WiFi does not work.

Posts: 16
Joined: Thu 9 Aug 2018 07:12

Re: Retrostone problems

Post by outz » Sun 19 Aug 2018 01:26

if 8bcraft would stop filtering forum posts, i would gladly tell you that there isn't a wifi chipset in the retrostone.

Posts: 8
Joined: Fri 17 Aug 2018 12:24

Re: Retrostone problems

Post by XorA » Sun 19 Aug 2018 21:03

Wifi does work if you plug in USB Wifi dongle.

Thats how I am using mine :-)

Posts: 6
Joined: Sun 19 Aug 2018 18:01

Re: Retrostone problems

Post by JohnnyPi » Mon 20 Aug 2018 03:56

XorA wrote:
Sun 19 Aug 2018 21:03
Wifi does work if you plug in USB Wifi dongle.

Thats how I am using mine :-)
Anyone have a quick list of cheap WiFi dongles that are compatable?

User avatar
Administrateur du site
Posts: 495
Joined: Sat 10 Dec 2016 13:12

Re: Retrostone problems

Post by Admin » Mon 20 Aug 2018 08:54

Hey guys,

@Nevuor I think dr_bunsen is probably correct, it's most likely a partition problem. Try using the diskpart tool to claim full capacity of the memory card.
See here how to do : ... n-sd-card/

XorA yes there's an UART available inside, it is indicated on the PCB silkscreen.

pbhound wifi is not included on the board. your should use a wifi dongle. I don't have a list of compatible ones yet, if you have one that works please post the model for the others :)

outz I don't filter messages, it's just a validation for new users to avoid spam messages on the forum.

Post Reply