New Retrostone user

Present yourself, make suggestions, tell what you think of the project, ask your general questions
Post Reply
Posts: 10
Joined: Thu 3 Jan 2019 18:55

New Retrostone user

Post by Aggdaddy »

Hello all. I have just joined the elite since I have received my retrostone and I wanted to share my experience with the device. Before the retrostone I have used a rasberry pi 3b+ for gaming on a 32inch tv and a Waveshare Gamehat. I'm a windows guy, so not totally familiar with linux and the like, but I can follow instructions. Overall I like the retrostone. The screen leaves alot to be desired, but the device is pretty nice.

When I received the retrostone I immediately got my 64GB microsd card prepared and formatted as exfat, as fat32 won't work on it. Used etcher to put on Supreme Retrostone image and then fired up the RetroStone. I was a little impatient waiting on the device to finish the expansion of the partition. Fortunately I read about that somewhere else that some images need to expand or be expanded before it will work, or would have never gotten a chance to see what the Supreme Retro image was all about. I was so close to turning it off since it was just sitting there with a powered on blank screen. '

So finally it finished and showed me the interface. Ahhh, my eyes. I can't read the text. The theme it is configured for on initial boot is hard on my eyes. Admittedly, I have a bit of astigmatism and I don't wear my glasses, ever, but I worked with the es themes enough to find that the box theme is the best for me. I tried downloading the others, but they were waaay way worse. After I transferred some roms to it, via the desk and USB disk method, I was able to see how it worked. Ugh, my hands are kinda big for this device. I can do the front buttons ok, but the back buttons are harder to position my hands over comfortably. I plan on doing the button and joystick mod mentioned in the tutorial to alieve that concern.

After playing with it a bit, I decided to play with the es themes some more, to make sure I have the best one. Played around with a few, before I attempted to come back to the box theme that the image comes with and bam, it locks up on me. The device is stuck on the process trying to load the box theme I can only assume. Perhaps it got corrupted some how. Power cycled the device once or twice and waited several minutes for it to hopefully process and show me an interface. nothing. Ahh well, back to the drawing board. Learned to stick with the box theme and don't change.

Reimaged my microsd card and decided to transfer my huge library of roms over the network. Does the device have wifi hardware or do I need to install drivers? I couldn't get the wifi to see my access points. Oh well, I just went upstairs and connected it to my network switch and left it connected to a usb hub to charge while I transfer the roms from my laptop over the network. This was working ok for a bit, until it got slower and slower. and eventually stopped responding I went back upstairs to see if the device was sleep or something and I saw an error on the screen.

ALSA lib pcm.c:7843:(snd_pcm_recover) underrun occurred.

This error was repeated all the way down the screen. Pressing start+select or B or the yellow buttong, did not bring it out of this state. Eventually I had to risk corrupting the sd card by turning the device off at the switch. Then the device would not POST correctly. After the initial Retrostone splash screen, I notice the led lights on the side. The one for system on and low battery would flash momentarily like a glitch blink or flash, not a software programmed blink or flash. The screen would illuminate blue and restart. It did this twice before I just powered it off and let it charge and cool down before trying the transfer. I could only assume that the problem was heat related, since it was on for an extended period of time with a charge cable connected to it while being used.

I left it alone for about 30 to 45 minutes and fortunately it powered back up and showed me the game system menu. I was seriously thinking about returning it and not wasting any more time with the device at this point, but I figured I would continue with the transfer. After about 90 minutes of file transfers I finished the bulk of my roms I wanted to test on the retrostone.

I also continued to get the above mentioned error, but the file transfers still went through at a decent transfer speed while that error was displayed. Weird?

They all worked, well all the roms I tested for each system. Even the dreamcast games. I had problems with the rasberry pi 3b+ and the image the dreamcast game came with, but the retrostone played it no problem. Tried my arcade games, nes, snes, Turbo Graphix, gameboy advance. They all worked flawlessly.

Hmm, I guess I'll have to keep it after all.

Rocky road getting it set up, but this may be a keeper after all. I just need to make a backup of my current image, in case of any corruption snafu's in the future.
Post Reply