Raspberry Pi Zero W 2 working

Here is all the tutorials, FAQ and support for RaspiBoy Kit
Post Reply
edbgon
Posts: 1
Joined: Thu 4 Nov 2021 11:21

Raspberry Pi Zero W 2 working

Post by edbgon » Thu 4 Nov 2021 11:44

A new Pi Zero W 2 showed up in my mailbox today and I've already got it working. There's a catch though, the new board does not have the solder pads located in the same spot for the composite video output, so some permanent modification is required and you should be handy with a soldering iron before ordering yourself a new pi.

The speed upgrade is fantastic and makes this device an entirely new experience. It still won't play N64 very well, but everything else loads so much more quickly. It's also great having built in wifi, which I didn't have on the original.

The first step is to flash the weekly Retropie image to the device. https://files.retropie.org.uk/images/weekly/
You should choose the rpi2_3 image because the new zero has a lot of the same equipment from the Pi 3. This step may not be necessary after a stable release of Retropie which will support this device.

Be sure to modify the config.txt as it should be done for the original Pi Zero for setting the framebuffer size and overscan. Don't worry about the audio part yet. Change the font size or get a theme for smaller screens as well.

To get video working:
The hardest part. Desolder the pogo pins from the 8bcraft PCB that touch the "TV" section on the original pi. Attach two small wires from the pads on the 8bcraft PCB and link them all the way over to the other side where "TV" is shown on the new PI board. Pay attention to which is ground, they kind of "cross" over since the new Pi has reversed these.

To get sound working:
There's changes in the sound configuration, so a new entry in the /boot/config.txt file is necessary.
The original starts dtoverlay=pwm-2chan..... replace it with the following:

Code: Select all

dtoverlay=audremap,pins_18_13,enable_jack=on
Additionally, I've heard that this can help with audio hiss, but I haven't confirmed this.

Code: Select all

disable_audio_dither=1

Post Reply