Activate WLAN

Please check here for help solving common issues.
Post Reply
Posts: 1
Joined: Thu 30 Jan 2020 20:17

Activate WLAN

Post by flyingangel » Thu 30 Jan 2020 20:22


Today I received my Retrostone 2 and I'm very happy with it!

But I have a little problem: Can WLAN be activated in the actual version of retrorangepi, or is it not possible to activate the onboard wifi-chip?

Thanks for your help!

User avatar
Administrateur du site
Posts: 496
Joined: Sat 10 Dec 2016 13:12

Re: Activate WLAN

Post by Admin » Fri 31 Jan 2020 10:46

Currently the wifi/bt chip is disabled by default because it's inducing some lag for an unknown reason. We'll activate it back when root issue will be identified.
This topic is more actively discussed on Retrorangepi forum.

Posts: 15
Joined: Thu 29 Nov 2018 20:14

Re: Activate WLAN

Post by OctavioS » Thu 16 Apr 2020 02:24

Hi, I just received my retrostone 2 and for what I see, the problem is still not solved?

Posts: 1
Joined: Sun 15 Mar 2020 17:38

Re: Activate WLAN

Post by j3kz » Fri 17 Apr 2020 16:32

I received mine yesterday...
I installed ... _v3.img.7z
I tried to setup wifi but unfortunately I cannot, no wlan0

dmesg gives one error related:
[ 28.360075] ieee80211 phy0: brcmf_p2p_create_p2pdev: timeout occurred
[ 28.360102] ieee80211 phy0: brcmf_cfg80211_add_iface: add iface p2p-dev-wlan0 type 10 failed: err=-5
[ 42.150702] brcmfmac: brcmf_sdio_dpc: failed backplane access over SDIO, halting operation
[ 42.696050] ieee80211 phy0: brcmf_fil_cmd_data: bus is down. we have nothing to do.
[ 42.696432] ieee80211 phy0: brcmf_fil_cmd_data: bus is down. we have nothing to do.
[ 42.698775] ieee80211 phy0: brcmf_fil_cmd_data: bus is down. we have nothing to do.
[ 42.698800] ieee80211 phy0: brcmf_cfg80211_get_channel: chanspec failed (-5)

It seems enabled and but wlan0 cannot start...

Posts: 2
Joined: Wed 20 May 2020 19:10

Re: Activate WLAN

Post by jay » Wed 20 May 2020 19:34

Any movement here? Possible to enable WiFi yet?

Posts: 2
Joined: Sun 14 Jun 2020 19:39

Re: Activate WLAN

Post by mycale » Sun 14 Jun 2020 19:40

I agree. It's been some months. Whats the status?

Posts: 3
Joined: Tue 16 Jun 2020 06:39

Re: Activate WLAN

Post by megashub » Tue 16 Jun 2020 06:40

+1 for this. Any movement on this issue? Just received mine today, and encountered the same problem. Would love to get this fixed.

Posts: 128
Joined: Wed 19 Dec 2018 14:43

Re: Activate WLAN

Post by Sakib » Tue 16 Jun 2020 08:44

Select Enable From Retropie - Retrorangepi - Wifi Submenu
Then You Select Connect, Then Activate A Connection
Available Access Point Should Appear Listed

Now choose the SSID from that list and type password (Connect a keyboard)

Post Reply